RPi2 openELEC gpio chip not found! IR-Receiver

Nachdem ich gestern testweise auf einem Raspberry Model B eine IR-Emfänger-Diode mittels lirc erfolgreich zum laufen gebracht habe, sollte dies natürlich auch auf dem Raspberry Pi 2 im Wohnzimmer erfolgen. Also: same procedure doch dann spuckte dmesg folgendes aus:

lirc_rpi: gpio chip not found!

Nun habe ich ein bisschen gegoogelt und bin darauf gestoßen, dass es Änderungen im Kernel gab und man solle sich damit befassen: Raspberry Pi Configuration Device Tree..

Auch das getan aber als Laie war ich damit etwas überfordert.

Nun bin ich darauf gestoßen, dass man

dtoverlay=lirc-rpi

in die config.txt unter /flash eintragen soll. Siehe hier und hier. ACHTUNG! Damit habe ich mir 4 mal die Installation zerschossen, sodass der Raspberry Pi 2 mit OpenELEC nicht mehr hochfuhr.

Zur meiner Lösung:

Als erstes habe ich /flash mit Schreibrechten gemountet:

mount /flash -o remount,rw

Dann in des besagte Verzeichnis gewechselt:

cd /flash

Dann mit nano die config.txt geöffnet:

nano config.txt

Und dann der entscheidende Unterschied:

device_tree_overlay=lirc-rpi

unten in die config.txt eingetragen

Mit Strg-X, Y und Enter die Datei speichern und schließen.

Nun mittels

reboot

den Raspberry neustarten und siehe da: es funktioniert. OpenELEC startet normal durch.

Wir loggen uns wieder mit putty über SSH ein und checken das ganze nochmal:

dmesg |grep lirc

sollte nun folgendes zutage fördern:

GPIO found

 

 

 

7 Gedanken zu „RPi2 openELEC gpio chip not found! IR-Receiver“

  1. Hi, ich habe Probleme mit dem Konfigurieren.
    Ich habe einen Raspberry Pi 2 und OpenELEC 5.0.5 ich habe schon alle tut`s im internet ausprobiert, leider immer ohne erfolg, ich bekomme mit “ mode2 -d /dev/lirc0 “ immer ausgaben beim drücken von Tasten auf der Fernbedienung, aber ich bekomme es nicht hin, dem Gerät beizubringen, dass es die Befehle ausführt. Kannst du mir sagen, wie du es zum laufen gebracht hast, ein Tutorial empfehlen oder machen.
    Danke
    Gruß max

  2. spannende Sache, ich habe einen TSOP4838 entsprechend den vielen Anleitungen angeschlossen, in der config.txt lediglich noch dtoverlay=lirc-rpi eingetragen, funktioniert soweit, mit irrecord dann die „Tasten“ bekannt gemacht, reboot… dann jedoch mein Problem, dass nur jeder 2. Tastendruck erkannt wird. Aber was mich interessiert, wieso geht das ohne device_tree? Hast du noch weitere Sachen am GPIO-Port? Oder gibt es vom RPi2 auch schon verschiedene Revisionen?

    Netten Tag,
    Andi

  3. Und wenn ich alles genau so mache, steht dann da:
    lirc_dev: IR Remote Control driver registered, major 243
    lirc_rpi: module is from staging directory, the quality is unknown, you have been warned.
    lirc_rpi: gpio chip not found!

    Ich bin frustriert. Warum ist das so schwer? Unter Raspbian funktioniert es ja auch…

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht.