Virus Warnung bei WordPress Theme Flat

Aktuelle benutze ich auf diesem Blog das Theme Flat in der Free-Version 1.7.1 von Themeisle.com.

Heute bekam ich plötzlich eine Mail von meinem AntiVirus-Plugin mit dem Hinweis auf einen Virus-Verdacht. Ich loggte mich also ein und machte nochmal eine manuelle Prüfung und siehe da:

Warnung_Antivirus-Wordpress-Theme-Flat

In der Theme-Datei /themes/flat/class-tgm-plugin-activation.php beanstandete das Plugin folgenden Code:

if ( ! WP_Filesystem( $creds ) ) {

Doch was tun als Programmier- und PHP-Laie? Auf jeden Fall die Ruhe bewahren und einmal ein anderes Theme aktiviert. Da lief der der AntiVirenScanner auch sauber durch. Also das Theme Flat einmal gelöscht und neu installiert. Doch auch dann erschien die Meldung wieder.

Googlen half relativ wenig weiter, ich landete nur auf irgendeinem WordPress-Hacker-Forum, was meiner inneren Ruhe nicht gerade gut tat. Also beschloß ich mich die Leute zu kontaktieren, die es wissen sollten. Ich kontaktierte Themeisle.com über das Support-Formular und WOW! Genau 7 Minuten später hatte ich eine Antwort in der Mailbox!

Resultat: Der Support ging von einem Fehlalarm aus. Er hatte die Webseite einmal von virustotal.com durchsuchen lassen mit dem Ergebniss, dass die Seite sauber sein. Darauf war ich in dem Schreck garnicht gekommen. Außerdem hatte er mir mal geraten einen anderen WordPress-VirenScanner zu testen und siehe da: mit Wordfence war alles sauber! Obwohl ich von den Plugins von Sergej Müller sehr begeistert bin, werde ich jetzt wohl Wordfence statt sein wpAntiVirus behalten. Es bietet genaue Einblicke, wo es genau einen Verdacht gefunden hat. Die Webseite von Wordfence bietet übrigens interessante Live-Statistiken. Also KEIN Virus in irgendwelchen WordPress-Dateien! Jetzt kann ich beruhigt wieder Kaffee trinken!

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.